Cant send to a moved email domain.


After removing a domain from the local Exchange 2003 server and moving to a different mail solution (cloud or on prem doesn’t matter) we were unable to send any more email to that domain at all…… it would get stuck in categorizer and return an NDR

We removed the Domain from the Email address policy as well as making sure it didn’t exist in the SMTP virtual server or any connectors.

 

After doing that we were still unable to send any email to the external domain ( mail tracking showed it getting an NDR from categorizer)

also any email sent to that domain from the new 2010 mail system on the same domain does work, so only mail from the 2003 does not work…… hmmm

After much log reading and troubleshooting the answer was in the IIS MetaBase. (increase categorizer logging and look for event 6015)

 

We had to use MetaBase explorer to remove the old removed domain from IIS\SMTP

To resolve this problem, follow these steps:

  1. Install IIS 6.0 Resource Kit Tools. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

    840671 (http://support.microsoft.com/kb/840671/ ) The IIS 6.0 Resource Kit Tools

  2. Open IIS Metabase Explorer.
  3. Expand LM, and then expand SmtpSvc.
  4. There are two items that are listed under SmtpSvc. 1 and another item If you expand the both items, you can see domain names.
  5. Right-click the invalid domain name, and then click Delete.
  6. Restart the Simple Mail Transfer Protocol service and the Microsoft Routing Engine service.

http://support.microsoft.com/kb/952841

Advertisements